Презентация

Элементы управления, диалоговые окна, используемые при работе с таблицами в Excel

Категория:

Презентация

Дисциплина:

Прикладное программирование

Город:

Беларусь, Минск

Учебное заведение:

БНТУ, ФИТР

Стоимость работы:

бесплатный

Оценка: 10
Объем страниц: 10
Год сдачи: 2017
Дата публикации: 22.10.2020

Фрагменты для ознакомления

Диалоговые окна и элементы управления – это основные инструменты взаимодействия пользователя с операционной системой Windows.

Элементы управления

Элементы управления представляют собой графические объекты, которые помещаются в форму для отображения или ввода данных, выполнение действий или облегчения чтения формы.

Элементы управления формы помогают быстро менять данные на листе в определённом диапазоне, включать и выключать опции, делать выбор и пр.

Для вставки элементов управления на лист необходимо отобразить вкладку Разработчик: открыть Файл -> Параметры -> Настроить ленту ->

Настройка ленты и в разделе Основные вкладки установить флажок Разработчик.

Теперь вставить элемент управления можно через меню: Разработчик/Элементы управления/Вставить.

Поле со списком – элемент управления формы

Поле со списком представляет собой сочетание текстового поля и раскрывающегося списка. Для того, чтобы отобразить список элементов, пользователь должен щёлкнуть стрелку.

Вставить элемент управления можно через меню: Разработчик/Элементы управления/Вставить/Поле со списком.

После этого выпадающее меню закроется, а курсор вместо обычного толстого крестика превратится в тонкий крестик.

Удерживая левую клавишу мыши проведите курсором вправо и немного вниз, элемент Поле со списком будет помещен на лист.

Заполняем Поле со списком элементами

Заполним Поле со списком наименованием товаров. Для начала разместим названия товаров на листе в диапазоне А12:А14.

Чтобы заполнить Поле со списком, кликните на него ПРАВОЙ клавишей мыши –> Формат объекта –> вкладку Элемент управления -> введите в поле Форматировать список по диапазону ссылку на вышеуказанный диапазон. Нажмите ОК, Поле со списком заполнится элементами.

Для того, чтобы Поле со списком возвращало выбранное значение в ячейку необходимо: кликнуть на него ПРАВОЙ клавишей мыши -> Формат объекта -> вкладку Элемент управления -> введите в поле Связь с ячейкой ссылку на ячейку. Свяжем наше Поле со списком с ячейкой     А2.

Счётчик – элемент управления формы

Элемент Счётчик позволяет изменять значения в определённом диапазоне с определённым шагом. По умолчанию диапазон изменения значений определён от 0 до 30000, шаг = 1.

Вставить элемент управления можно через меню: Разработчик/Элементы управления/Вставить.

После этого выпадающее меню закроется, а курсор вместо обычного толстого крестика превратится в тонкий крестик.

Чтобы связать Элемент управления с ячейкой, кликните на него ПРАВОЙ клавишей мыши –> Формат объекта -> Элемент управления -> в поле Связь с ячейкой ввести ссылку на ячейку. Свяжем наш Счётчик с ячейкой В2.

Создание формы в Excel на VBA

Создаём Макрос и заходим в раздел редактирования (Изменить) для создания формы расчёта.

В редакторе VB щёлкнуть правой кнопкой мыши по проекту в окне Project Explorer и в контекстном меню выбрать Insert –> User Form. Откроется окно дизайнера форм, в котором будет представлено пустое серое окно формы и рядом – Toolbox, панель с набором элементов управления.

После создания формы, вы должны обеспечить запуск этой формы в документе. Для запуска формы нужно воспользоваться методом Show() -> UserForm1.Show.

Добавляем на Форму кнопки, список, поле со списком и текст. Выбираем необходимый элемент из таблицы Toolbox и перетаскиваем на Форму.

Изменяем код самих кнопок. Правой кнопкой мыши щёлкаем на Форму и заходим в код Формы.

Создаём фигуру с названием Расчёта стоимости продукции и назначаем ей наш созданный Макрос, нажатием правой кнопки мыши и выбор из меню.

При нажатии на данную фигуру, будет выскакивать наша созданная Форма, где мы можем выбрать диапазон скидок, выбрать способ доставки и рассчитать стоимость, либо закрыть Форму.

Также необходимо заполнить формулами рабочие ячейки: Цена, Стоимость, Итого, К оплате. В ячейке Цена - =ИНДЕКС(B12:B14;A2). Стоимость - =B2*C2. Итого - =D2-D2*F5. К оплате - =ЕСЛИ(F6="Доставка на дом"; C5*E13;C5*E12).

При нажатии на кнопку Формы Рассчитать, в ячейке К оплате будет изменяться значение стоимости к оплате.

241